Supported Computer Software

Details

Information Technology Services consulting staff are prepared to assist any Dartmouth student, faculty, or staff member with any of the software listed below. We have experience with and resources available to provide support.

You may choose to use applications not found on this list. In fact, many other items are available for purchase through the Computer Store or are available for download from the Software Downloads page (which is a subset of what is available here and supported by Information Technology Services). Other groups on campus may provide support for these applications or for other operating systems.

If the operating system or software you are using or planning to purchase does not appear on this list, please contact your department's IT support office. They may be able to offer alternatives or refer you to a more appropriate group or outside resource for support.

Note: Due to limited resources, we generally do not provide support for software older than four years or for non-English versions of operating system installations. We also do not support software no longer supported by the manufacturer or pre-released (alpha or beta) versions of any computer software.

Supported Software

See specific details about the Dartmouth and Microsoft Campus Agreement.

Supported Operating Systems (OS)

Desktop Applications

Note: Information Technology Services recommends keeping applications up-to-date, including applying available software updates. Many applications have an automatic mechanism when you run a particular application; you may also connect directly to the vendors Web site.

  • Adobe Acrobat Reader version XI and higher
  • Adobe Acrobat Pro version XI and higher
  • F5 Big-IP (F5 Access) VPN Client
  • Fetch version 5.x or higher
  • FileMaker (versions 12 and higher)
  • GreenPrint version 8.0 and higher for Windows and Macintosh
  • Internet Explorer version 11 and higher for Windows (Internet Explorer is no longer distributed with Macintosh computers or supported by Microsoft for use on Macintosh computers.)
  • JellyfiSSH version 4.5.2 and higher
  • KeyAccess version 7.2 and higher for Windows and version 7.2 and higher for the Macintosh
  • Microsoft Office 2016, 2013, 2011, 2010 and higher (only Word, PowerPoint, Outlook and Excel; MS Office 32-bit version required for use with the Web ADI tool.)
  • Mozilla Firefox version 30.0 and higher
  • Mozilla Thunderbird version 30.0 and higher
  • Parallels version 9 and higher
  • Safari version 7 and higher
  • SSH Secure Shell version 3.2.9 and higher
  • Symantec EndPoint Protection version 11.x and higher for Macintosh (v 12 and higher recommended)
  • VMWare Fusion version 8 and higher
  • Windows Defender for Windows

Handheld Device OS Applications

Also see:

Topic: 
Computer and Device Services
Subtopic: 
Desktops and Laptops
Last updated: 
Tuesday, March 28, 2017
Close
Information Technology Services